GigE Vision Camera Appears in NI MAX but Not in LabVIEW

Updated May 3, 2018

Reported In

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Driver

  • NI-IMAQdx
  • Vision Acquisition Software

Issue Details

My GigE Vision camera appears in NI Measurement & Automation Explorer (NI MAX) but it does not enumerate in my LabVIEW camera selector.  If I type the same camera name in LabVIEW that I see in NI MAX, I get an error on Open Camera.vi

Solution

Look into the following items that may be the cause of this behavior:
  • Check to make sure the VI is set to run on the correct target you are expecting.​  In the image below, the VI is set to run on My Computer.
  • Open up a vision example such as Grab.vi in Help >> Find Examples ... >> Hardware Input and Output >> Vision Acquisition >> NI-IMAQdx >> High-Level >> Grab.vi to make sure the issue is not in your particular VI.
  • Try disabling your firewall.  If that works, make sure that you have allowed proper permission for LabVIEW in your firewall.
  • Try accessing the GigE Vision camera via its IP address in LabVIEW.  Use ip:<ip addr> to specify your camera instead of using the camera drop-down. 
  • If you look in C:\Windows\SysWOW64 for niimaqdx.dll, right-click on it >> properties >> details, note the version number.  Now do the same for niimaqdx.dll in C:\Windows\System32.  The version numbers should match.  If they do not match, the install is in a bad state.

WAS THIS ARTICLE HELPFUL?

Not Helpful