Error -1074100593 When Running the NI-USRP Simple Streaming Project

Updated Aug 6, 2019

Reported In

Hardware

  • USRP-2953

Software

  • LabVIEW 2014

Driver

  • NI-USRP 17.2

Issue Details

I am using LabVIEW 2014. After installing NI-USRP 17.2, I successfully created a NI-USRP Simple Streaming project. However, when I run the project, I got the error -1074100593. How can I solve this problem?

Solution

The error occurs because the version of NI-USRP is not compatible with the version of LabVIEW. According to NI-USRP 17.2 Readme, the driver NI-USRP 17.2 supports LabVIEW 2014 SP1, while it doesn't support LabVIEW 2014. By installing the compatible versions of LabVIEW and NI-USRP, you should be able to resolve the error and run the project successfully.

Additional Information

The error may also appear when NI-USRP driver doesn't support the specific USRP hardware. You can find the driver readme file for supported device list, and install the correct and compatible version of NI-USRP driver.

WAS THIS ARTICLE HELPFUL?

Not Helpful