Error 'Need Base System 15.0.0' When Installing SystemLink 19.0 on Linux RT cDAQ

Updated Jul 12, 2019

Reported In

Hardware

  • cDAQ-9137
  • cDAQ-9134
  • cDAQ-9135
  • cDAQ-9132
  • cDAQ-9133
  • cDAQ-9136

Software

  • SystemLink
  • SystemLink Client

Issue Details

When I try to install SystemLink Client 19.0 on the NI Linux Real Time cDAQ, I get the following prompt:



How can I resolve this and continue installing SystemLink?

Solution

1. Install LabVIEW Real-Time Module 19.0 or higher version which include the Base System 15 required for the installation on your computer.
2. Install SystemLink Client 19.0,  LabVIEW Real-Time 19.0 and other drivers to the cDAQ Target using NI-MAX.