Which FPGA Compiler Do I Need for FPGA Devices with Virtex 7, Zync, and Kintex-7 Chips?

Updated Jun 28, 2019

Reported In

Hardware

  • USB-7855

Software

  • LabVIEW FPGA Compilation Tool for Vivado 2017.2
  • LabVIEW FPGA Compilation Tool for ISE 14.7
  • LabVIEW FPGA Module

Programming Language

  • LabVIEW G

Issue Details

I  am using LabVIEW 2018 to to develop and deploy FPGA code onto  a USB-7855R that uses the Kintex-7 chip. Looking at the Compatibility between Xilinx Compilation Tools and NI FPGA Hardware , it seems I need to have at least FPGA compilation tool  ISE 14.4.

Since I am using LabVIEW 2018, I have installed ISE 14.7, but I cannot compile the FPGA.
Why is this occurring?

Solution

Depending on which LabVIEW version you are using, the Xilinx Compilation tool will be different for devices that use the Virtex 7, Zync, and Kintex-7 FPGA chips.

LabVIEW 2014 and above:
You must use the Xilinx Compilation Tools Vivado to compile. To find which Vivado version is compatible with your LabVIEW version, please refer to Compatibility between Xilinx Compilation Tools and NI FPGA Hardware

LabVIEW 2013 SP1 and below:
You must use the Xilinx Compilation Tools ISE 14.4 to compile.

 

Additional Information

If you are using LabVIEW 2014 and above and you would like to compile for FPGA chips other than Virtex 7, Zync, and Kintex-7 that are supported in ISE 14.4, you must use ISE 14.7.

To find which FPGA chip you FPGA device is using, please refer to Xilinx FPGA Chips for National Instruments RIO Devices