使用VeriStand Steps for TestStand設定程序時出現Error 1172

更新 Nov 10, 2020

產品資訊

軟體

  • TestStand
  • VeriStand

問題敘述

我有使用透過Veristand 2017和TestStand 2017所開發出來的程式碼,最近我更新到了VeriStand 2018版本。現在當我從TestStand載入VeriStand 2018程式碼時,會看到以下錯誤。


Details: 
Error executing subset 'StartVeristand'. 
Error code: 1172; User-defined error code.

 

解決方案

發生該錯誤的原因是當您安裝了多個版本的VeriStand時,TestStand無法載入相應版本的VeriStand。要解決此問題,您需只安裝一種版本的VeriStand並刪除舊版的VeriStand。

相關資訊

VeriStand Steps for TestStand是一組可自訂的TestStand程序類型,最初是由NI R&D開發用於TestStand程序下自動執行VeriStand。但是該工具已被捨棄,NI不再支援該工具。NI不建議您使用它,且僅會提供它現有的版本狀態。

未來請使用ASAM XIL Steps for TestStand,您可透過NI Package Manager來進行安裝。