NI-488.2 Installation Errors on macOS 10.13

Updated May 17, 2019

Reported In

Driver

  • NI-488.2

Other

  • macOS 10.13

Issue Details

I am having problems installing NI-488.2 on my computer running macOS 10.13. After installation, the NI-488.2 Troubleshooting Wizard throws the error The NI-488.2 Software is not correctly installed on your system.
 

Additionally, the GPIB Explorer throws the error Failed to get all configured GPIB interfaces.
 

How can I get the NI-488.2 driver installed correctly on my machine?
 

Solution

A new kernel extension blockage feature was introduced in macOS 10.13. With this new feature, any newly installed kernel extension from NI will be blocked by the operating system until you explicitly accept it. This is a manual process that is not possible to automate. You can follow these steps to remove the kernel extension blockage:
  1. Install a compatible version of NI-488.2.
  2. Navigate to System Preferences on your computer.
  3. Select Security & Privacy.
  4. In the General tab, there should be an option to unblock kernel extension in the lower right corner.
  5. After unblocking the kernel extension, reboot the system.

WAS THIS ARTICLE HELPFUL?

Not Helpful