몪음 프로젝트 라이브러리는 LabVIEW 버전 간에 호환됩니까?

업데이트 됨 Jun 4, 2021

해당 제품

소프트웨어

  • LabVIEW
  • LabVIEW Application Builder Module

문의사항

묶음 프로젝트 라이브러리 (PPL)를 내장 된 것과 다른 버전의 LabVIEW에서 사용할 수 있습니까?

해결책

LabVIEW 2016 또는 이전 버전에서 컴파일 된 PPL은 다른 버전의 LabVIEW를 사용하여 열 수 없습니다. 예를 들어, LabVIEW 2016을 사용하여 LabVIEW 2011에서 컴파일 된 PPL을 열려고하면 다음과 같은 오류 메시지가 나타납니다.

LabVIEW : (Hex 0x623) 현재 LabVIEW 버전이 아닌 이전 버젼에서 저장된 묶음 라이브러리는 열 수 없습니다.

Error Image.PNG

LabVIEW 2017 부터는 최신 버전의 LabVIEW와 함께 사용할 묶음 프로젝트 라이브러리를 컴파일 할 수 있습니다. 빌드 스펙 프로퍼티 의 사이드 바 항목에서 고급 을 선택하고 다음 LabVIEW 버젼에서 이 묶음 라이브러리를 로드하도록 허용 옵션을 활성화합니다. 이 옵션은 기본적으로 활성화되어 있습니다.

Exe Property Prompt.PNG

추가 정보

LabVIEW 2017 이후로 어플리케이션 , 공유 라이브러리.NET 어셈블리에 대한 하위 호환성을 활성화 할 수도 있습니다.