How to Downgrade NI Measurement and Automation Explorer (NI MAX)?

Updated Jun 14, 2019

Reported In

Software

  • Measurement & Automation Explorer (MAX)

Driver

  • NI-DAQmx
  • NI-DAQmx 9.1

Issue Details

  • I upgraded DAQmx by mistake in my computer, and, therefore, NI MAX was also updated.  I want to keep DAQmx as the previous version, so I uninstalled the more recent DAQmx version. Nevertheless, the NI MAX version did not downgrade and stayed on the recent version.  Currently, the DAQmx version installed is not the one that pairs up with the NI MAX version. Could this cause a problem? Is it possible to downgrade NI MAX only?  Are more recent versions of NI MAX compatible with older versions of DAQmx? 
  • Can I downgrade MAX without having to uninstall all of the software packages it requires me to uninstall? 

Solution

  • Are more recent versions of NI MAX compatible with older versions of DAQmx? 
    • Yes, higher versions of NI MAX will always support lower versions of NI-DAQmx. 
 
  • Can I downgrade NI MAX itself?
    • No, NI MAX cannot be downgraded itself, nor can it be installed lonely.  NI MAX is installed along with either NI System Configuration, NI-DAQmx, NI-DAQ, NI VISA and other NI drivers. As a result, NI MAX itself cannot be downgraded as a separate software entity.  To downgrade NI MAX, you will need to uninstall it from the NI Package Manager, and it will remove many other software packages along with it. A permission will need to be granted for all these packages to be uninstalled.  After uninstalling NI MAX and these packages, all the drivers that were removed during the process will then need to be reinstalled manually. 
    • The following link contains a table with the DAQmx/NI MAX pairing: Measurement & Automation Explorer (MAX) Version Installed with NI-DAQmx Drivers

Additional Information

NI recommends to keep the drivers updated up to their latest version as long as it is compatible with your hardware, operating system and LabVIEW versions. Please check the Related Links section for more information about compatibility between DAQmx, NI MAX and your Operating System and LabVIEW.