Determine If a Function Can Be Used in LabVIEW Base

Updated May 7, 2020

Reported In

Software

  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Issue Details

  • I developed a VI using LabVIEW Full Development but now I need to know if this VI will run in LabVIEW Base. How can I determine the compatibility between them?
  • How can I determine which Edition of LabVIEW should I have to be able to use a specific function?
  • Why am I getting "Library is expired or invalidly licensed" when trying to run my VI?

Solution

You can find the minimum required edition of LabVIEW that a function needs to work in the Help section of the specific function. The Edition can be Base, Full or Professional Development System. This information can be found by searching for the function or group of functions in your search engine.

Alternatively, if you have the function in your block diagram then the following steps will tell you what edition you require:

     1. Right-Click in a function placed on the Block Diagram of the VI:
     2. Select Help:


     3. In the LabVIEW Help window you will find the minimum required edition of LabVIEW to be able to use it:
 

 

Additional Information

You can find the main differences between the LabVIEW Editions in Select Your LabVIEW Edition.