TestStand Runtime Engine Version Compatiblity

Updated Apr 5, 2019

Reported In

Software

  • TestStand
  • TestStand Runtime

Issue Details

I have sequence files created in TestStand 2014 but have deployment machines with TestStand 2017 Runtime Engine installed.  Can I run the older sequence files on the newer runtime engine? 

Solution

In order to run sequence files, you will need to runtime engine of the version they were created in installed. There is no cross compatibility between TestStand Runtime Engines. For instance, if you have TestStand 2014 sequence files, you will need to have the TestStand 2014 Runtime Engine.