Archived:Which Drivers Are Required for My SCXI Modules?

Updated Oct 27, 2022

NI does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Reported In

Hardware

  • Chassis for SCXI

Driver

  • NI-DAQmx

Issue Details

I want to know which driver to install so I can work with my SCXI modules. How do I check the compatibilities between the driver versions and the hardware?

Solution

The driver needed for the SCXI hardware is NI-DAQmx

To check the compatibility between the driver version and the LabVIEW version, see the Compatibility Table.

To check the compatibility between the driver version and the hardware used, check the readme of the driver. For example, if you are working with NI-DAQmx 17, open the Readme from the download link and search for your device in the SCXI modules listed as supported by the driver.

Note: Support for SCXI was dropped in NI-DAQmx 19.1 and later.

Additional Information

In the Readme file, you can find all the information concerning the compatibilities (OS, driver version, software version and hardware).