Can I Install NI-DAQmx on Ubuntu?

Updated Aug 6, 2020

Reported In

Driver

  • NI-DAQmx
  • NI-DAQmx Base

Operating System

  • Linux

Issue Details

I am running a computer with an Ubuntu operating system. Is NI-DAQmx or NI-DAQmx Base supported on Ubuntu?

Solution

As of the NI Linux Device Drivers 2020, NI-DAQmx is supported on Unbuntu 18.04. Prior to this version, NI-DAQmx was not supported on Unbuntu. 
Please see the NI-DAQmx for Linux 20.1 readme for a list of devices supported by the NI-DAQmx for Linux driver.

After downloading the NI Linux Device Drivers, you can follow the guide on Downloading and Installing NI Driver Software on Linux Desktop to get started using your drivers on Linux.

Additional Information

NI also supports, CentOS, Red Hat, Scientific Linux, and OpenSUSE LEAP operating systems.

Ubuntu utilizes Debian package installers which, prior to NI Linux Device Drivers 2020 were not supported by NI-DAQmx or NI-DAQmx Base.

If you are trying to use a previous version of NI-DAQmx with Unbuntu, this is not officially supported. However, there are utilities available that can make the conversion from RPM installers (used by other types of Linux and supported by NI-DAQmx and NI-DAQmx Base) to Debian package installers, potentially allowing for the installation of NI-DAQmx on Unbuntu, prior to version 20.1.
Some users have documented their experience on the Linux support forums, NI-DAQmx Base 15.0 on Ubuntu 14.04 LTS 64 bit and How can I install NI-DAQmx on ubuntu 14.04, but they have had varying levels of success.
For more information about converting RPM package files into Debian package file reference External Link: RPM/AlienHowto.