Compile FPGA Code for PCI-7811R on Windows 10

Updated Mar 28, 2019

Reported In

Hardware

  • PCI-7811

Software

  • LabVIEW
  • LabVIEW FPGA Module
  • LabVIEW FPGA Compilation Tool for Vivado 2017.2
  • FPGA Xilinx Compilation Tools

Operating System

  • Windows

Issue Details

I am trying to compile my FPGA code for my PCI-7811R, but am getting a warning that the Xilinx ISE 10.1 Compilation Tools aren't installed.  I didn't install them because Xilinx ISE 10.1 isn't supported on Windows 10.  I installed Vivado to compile my code.  Why isn't the compiler looking at Vivado?

Solution

The PCI-7811R is a Virtex-II FPGA which is not supported on Vivado .

There are two options to compile your code for the PCI-7811R on a Windows 10 computer:
  1. Use the Cloud Compile Server to compile your code. To access this service you will need to have National Instruments Standard Service Package .
  2. Revert to an older OS that is compatible with the Xilinx ISE 10.1 compiler tools .

WAS THIS ARTICLE HELPFUL?

Not Helpful