Unresolved Dependencies When Trying to Install NI-XNET on CompactRIO Controller

Updated Mar 27, 2019

Reported In

Hardware

  • CompactRIO Controller

Driver

  • NI-XNET 18.5
  • NI CompactRIO

Issue Details

I cannot install NI-XNET 18.5 on my CompactRIO controllers because I receive the following error:

 

Cannot continue because of the following unresolved dependencies:


NI-XNET 18.5.0 requires NI-RIO IO Scan 18.0.0

NI-XNET 18.5.0 requires DECoM Driver 18.0

 

The only NI-RIO IO Scan version available in my host computer is 17.0. However, I have already installed NI CompactRIO 18.5.

Solution

Force-reinstall the NI CompactRIO Device Drivers.

 

If you don't have installed the NI CompactRIO Device Drivers version mentioned in the error message, download and install this version or a later one on the host computer.

Additional Information

WAS THIS ARTICLE HELPFUL?

Not Helpful