cRIO 904x Compatibility With NI 986x Modules

Updated Sep 7, 2018

Reported In

Hardware

  • cRIO-9047
  • NI-9860
  • NI-9862
  • NI-9861
  • NI-9866

Driver

  • NI-XNET 17.5.1
  • NI CompactRIO 17.6

Issue Details

I have a NI 9860: can I use it with a cRIO 9047?

Solution

The NI 986x modules require NI XNET drivers to be installed on the cRIO device in order for the controller to work with such modules.
The first NI XNET version including support for the cRIO 904x is the NI XNET 17.5.1

Additional Information

You will need NI CompactRIO 17.6 or higher and NI XNET 17.5.1 or higher and a compatible LabVIEW version in order to add a cRIO 904x having NI 986x modules to a LabVIEW Project. 

WAS THIS ARTICLE HELPFUL?

Not Helpful