Installing SystemLink on cRIO Gives 'Missing Base 15.0' Error

Updated Aug 30, 2018

Reported In

Hardware

  • Industrial Controller
  • CompactRIO Controller

Software

  • LabVIEW
  • SystemLink

Driver

  • NI CompactRIO
  • Industrial Controller Device Drivers

Issue Details

I am trying to install SystemLink Client 18.0 on my cRIO but I get an error:

NI SystemLink Salt 18.0.0 needs Base System 15.0.0
Legacy FTP Server (deprecated) 1.4.0 needs LabVIEW Real-Time 18.0
​NI SystemLink Client 18.0.0 needs Base System 15.0.0

​How can I resolve this and continue installing SystemLink?

Solution

Install NI-CompactRIO 18.0 or later which include the Base System 15 required for the installation.

Additional Information

SystymLink Client is not supported on Industrial Controllers but it is possible to install it on one. For an IC, installing the Industrial Controller Device Drivers 18.0 resolves this error.

WAS THIS ARTICLE HELPFUL?

Not Helpful