FPGA VI on NI 9144/9145 Does Not Support Interactive Mode

Updated Oct 4, 2018

Reported In

Hardware

  • NI-9145
  • NI-9144

Software

  • LabVIEW
  • LabVIEW FPGA Module

Driver

  • NI-Industrial Communications for EtherCAT

Issue Details

I have developed an FPGA VI for my NI-9145 and when I try to run it, I see the message You cannot run this VI because this target does not support interactive mode. How can I run my FPGA VI?
 

Solution

The NI-9144/9145 does not support interactive mode but you can deploy the bitfile to the chassis as usual and communicate with it using User-Defined I/O variables.

WAS THIS ARTICLE HELPFUL?

Not Helpful