Error -1074384758 When Using A USB-8472 With The NI-XNET Compatibility Layer For NI-CAN

Updated Aug 22, 2018

Reported In

Hardware

  • USB-8472

Driver

  • NI-XNET
  • NI-CAN

Issue Details

I enabled the NI-XNET Compatability Layer For NI-CAN to use with my USB-8472. When I try to run the NI example CAN Input Stream VI I see "Error -1074384758 occurred at XNET Create Session".

Solution

The USB-8472 hardware is only compatible with the NI-CAN driver. The CAN Input Stream VI example uses the NI-XNET API. The NI-XNET Compatibility Layer For NI-CAN is able to interpret code built using the NI-CAN API for NI-XNET compatible hardware. This feature is not able to run NI-XNET code on NI-CAN hardware. To use the USB-8472, use only the NI-CAN API. 

Additional Information

The final update to NI-CAN is version 17.0. This driver is supported up to LabVIEW 2017. The use of this driver will not be supported in versions 2018 and on.