Add NI-VirtualBench 17 Functions to LabVIEW 2018

Updated Jul 12, 2018

Reported In

Software

  • LabVIEW 2018

Driver

  • NI-VirtualBench Application and Driver

Issue Details

I have manually added the VirtualBench 17.0 Sub-VIs to LabVIEW 2018's vi.lib. This allows me to open a VI containing VirtualBench elements without LabVIEW asking me for missing libraries. However, when I want to add a VirtualBench element into a VI, they do not exist on the Functions Palette. Basically, when I right-click the Block Diagram to open the Functions Palette, and navigate to Measurement I/O, then I do not see any entry for VirtualBench to browse or choose from.

Also, I cannot compile any VI containing VirtualBench Sub-VIs, as LabVIEW shows they are broken.

Is there a way to make this work?

Solution

Note: The use of VirtualBench 17.0 with LabVIEW 2018 is currently not supported. The following workaround is a temporary fix until VirtualBench 18 is released. It can not be guaranteed to provide a fully working solution.

Note: This adaption steps are not needed when you install a version of NI-VirtualBench along with a version of LabVIEW it supports, e.g. NI-VirtualBench 16.x with LabVIEW 2016, NI-VirtualBench 17.x with LabVIEW 2017 etc.


Adaptions have to be made regarding the Functions Palette, Controls Palette, resource files, and help files. The following table gives a high-level overview, find detailed guidance for all adaptions below.

Note: The files that have to be copied are also attached to this article in a zip archive. Downloading the archive and extracting it to your LabVIEW 2018 folder might be easier than locating them manually. However, the attached files support only the English language version of VirtualBench 17 for LabVIEW 32bit.
 
Files and folders to copy
What?From...To...
VirtualBench VIs[...]\LabVIEW 2017\vi.lib\VirtualBench[...]\LabVIEW 2018\vi.lib\VirtualBench
Functions Palette elements[...]\LabVIEW 2017\menus\Categories\Measurement\lci2.mnu[...]\LabVIEW 2018\menus\Categories\Measurement\lci2.mnu
Controls Palette elements - Silver[...]\LabVIEW 2017\vi.lib\userdefined\Silver\VirtualBench[...]\LabVIEW 2018\vi.lib\userdefined\Silver\VirtualBench
Controls Palette elements - Modern[...]\LabVIEW 2017\vi.lib\userdefined\High Color\VirtualBench[...]\LabVIEW 2018\vi.lib\userdefined\High Color\VirtualBench
Controls Palette elements - Classic[...]\LabVIEW 2017\vi.lib\userdefined\Low Color\VirtualBench[...]\LabVIEW 2018\vi.lib\userdefined\Low Color\VirtualBench
Resource Files[...]\LabVIEW 2017\resource\objmgr\lci*.*[...]\LabVIEW 2018\resource\objmgr\
Help Files[...]\LabVIEW 2017\help\lciviref.*[...]\LabVIEW 2018\help\
Help Files[...]\LabVIEW 2017\help\index\lcivrref.chmeng[...]\LabVIEW 2018\help\index\lcivrref.chmeng

Additional Information

VirtualBench VIs
Follow the guide Integrate Support for NI-VirtualBench 17 in LabVIEW 2018 to manually make the VirtualBench elements available in LabVIEW 2018.


Functions Palette
Follow these steps to add the VirtualBench subpalette to the LabVIEW Functions Palette, and to include the VirtualBench elements in Quick Drop:
  1. Open LabVIEW 2017 and navigate to menu Tools » Advanced » Edit Palette Set...
  2. In the now-shown Functions Palette: click Measurement I/O, right-click VirtualBench, and click Display Path To Palette File...
  3. Note the path shown. For LabVIEW 2017 32bit, it typically is C:\Program Files (x86)\National Instruments\LabVIEW 2017\menus\Categories\Measurement\lci2.mnu
  4. Click Cancel in the Edit Controls and Functions Palette Set window.
  5. Close LabVIEW 2017.
  6. Navigate to the file from step 3 and copy it to the corresponding folder in your LabVIEW 2018 installation, typically C:\Program Files (x86)\National Instruments\LabVIEW 2018\menus\Categories\Measurement\
  7. Open LabVIEW 2018. It should automatically detect the new .mnu file and already show the VirtualBench subpalette as Functions Palette » Measurement I/O » VirtualBench. If not, perform step 9 while following along with the further steps.
  8. Navigate to menu Tools » Advanced » Edit Palette Set...
  9. Perform the following sub-steps if the VirtualBench subpalette was not added automatically to the Functions Palette:
    1. Click Measurement I/O in the now-shown Functions Palette, then right-click an empty space in this palette and select Insert » Subpalette...
    2. In the dialog window, select Link to an existing palette file (.mnu) and click OK.
    3. Navigate to the file from step 6.
  10. Right-Click the new VirtualBench subpalette and click Rename Subpalette...
  11. Change the name to e.g. VirtualBench2017, click OK.
  12. Click Save Changes in the Edit Controls and Functions Palette Set window, and confirm the changes in the Preview Palette Changes window by clicking Continue.

Controls Palette
Then, follow these steps to add the VirtualBench subpalette to the LabVIEW Controls Palette. This is compulsory, otherwise all Instrument Handles are broken.
  1. Open LabVIEW 2017 and navigate to menu Tools » Advanced » Edit Palette Set...
  2. In the now-shown Controls Palette: click Silver » I/O, right-click VirtualBench, and click Display Path To Palette File...
  3. Note the path shown. For LabVIEW 2017 32bit, it typically is C:\Program Files (x86)\National Instruments\LabVIEW 2017\vi.lib\userdefined\Silver\VirtualBench\dir.mnu​. Notice that there are more files than dir.mnu in this folder.
  4. Repeat the last two steps for the Modern and Classic subpalette as well. The corresponding files are typically C:\Program Files (x86)\National Instruments\LabVIEW 2017\vi.lib\userdefined\High Color\VirtualBench\dir.mnu and C:\Program Files (x86)\National Instruments\LabVIEW 2017\vi.lib\userdefined\Low Color\VirtualBench\dir.mnu.
  5. Click Cancel in the Edit Controls and Functions Palette Set window.
  6. Close LabVIEW 2017.
  7. Navigate to the folders from step 3 and 4 containing dir.mnu among other files, and copy the whole folders to the corresponding paths in your LabVIEW 2018 installation, typically C:\Program Files (x86)\National Instruments\LabVIEW 2018\vi.lib\userdefined\Silver\, respectively \High Color\ and \Low Color\.
  8. Open LabVIEW 2018. It should automatically detect the new files and already show the VirtualBench subpalettes as Controls Palette » <Silver/Modern/Classic> » I/O » VirtualBench. If not, perform step 10 while following along with the further steps.
  9. Navigate to menu Tools » Advanced » Edit Palette Set...
  10. Perform the following sub-steps if the VirtualBench subpalettes were not added automatically to the Controls Palette:
    1. Click <Silver/Modern/Classic> » I/O in the now-shown Functions Palette, then right-click an empty space in this palette and select Insert » Subpalette...
    2. In the dialog window, select Link to an existing palette file (.mnu) and click OK.
    3. Navigate to the corresponding file from step 7.
  11. Right-Click the new VirtualBench subpalette and click Rename Subpalette...
  12. Change the name to e.g. VirtualBench2017, click OK.
  13. Click Save Changes in the Edit Controls and Functions Palette Set window, and confirm the changes in the Preview Palette Changes window by clicking Continue.

Resource Files
Copy the five files beginning with lci, and having one of the two file extensions .rc and .rch from C:\Program Files (x86)\National Instruments\LabVIEW 2017\resource\objmgr\ to C:\Program Files (x86)\National Instruments\LabVIEW 2018\resource\objmgr\, respective the corresponding folders of your LabVIEW installations.


Help Files
Follow these steps to add the VirtuelBench help files to LabVIEW 2018:
  1. Copy the files lciviref.chm and lciviref.txt from C:\Program Files (x86)\National Instruments\LabVIEW 2017\help to C:\Program Files (x86)\National Instruments\LabVIEW 2018\help.
  2. Copy the subfolder lcivrref.chmeng from C:\Program Files (x86)\National Instruments\LabVIEW 2017\help\index\ to C:\Program Files (x86)\National Instruments\LabVIEW 2018\help\index\.

 

WAS THIS ARTICLE HELPFUL?

Not Helpful