Displaying Unicode Language Characters in LabVIEW on Windows

Updated Sep 20, 2018

Reported In

Software

  • LabVIEW

Operating System

  • Windows

Issue Details

On a computer running Windows, I want to read a file into LabVIEW that contains Unicode characters. When I do this, some of the characters are replaced by question marks even though the characters were displayed correctly in my file. Can I display these characters correctly in LabVIEW?

Solution

Unicode languages can be displayed by modifying the LabVIEW configuration file. The availability of display languages depends on the version of Windows, consider that only Windows 7 Ultimate and Enterprise allow users to choose a display language with the steps shown in Displaying Non-English Characters in LabVIEW. Windows 7 Professional is not able to download some of the very common language libraries that are listed in the Microsoft Knowledge Base: Download Languages for Windows

To display Unicode languages, modify the LabVIEW .ini configuration file, using the following steps:
  1. Navigate to
C:\Program Files (x86)\National Instruments\<LabVIEW>\LabVIEW.ini
  1. Add UseUnicode=TRUE to any new line in the LabVIEW .ini file.
  2. Save the file and exit LabVIEW. Upon relaunching LabVIEW, the Unicode characters should work correctly, whether typing or pasting in. 

For control/indicator labels, it may be necessary to enter text as a Caption, not a Label. Right-click on the control/indicator and select Visible Items»Caption from the right-click menu. 

Note: When building an executable that requires Unicode characters, insert the UseUnicode=TRUE line into the application .ini file generated with the executable.

Additional Information

LabVIEW for Windows has limited support for Unicode strings in the front panel controls and indicators. This is not an officially supported feature.

WAS THIS ARTICLE HELPFUL?

Not Helpful