Installing NI Video Measurement Suite (VMS) to Newer Versions of TestStand and LabVIEW

Updated Aug 1, 2018

Reported In

Software

  • Video Measurement Software
  • LabVIEW
  • TestStand

Issue Details

  • I have a version of NI Video Measurement Suite (VMS) that does not support a newer version of TestStand or LabVIEW that I would like to use. For example, I have LabVIEW 2014 and I would like to install NI VMS 3.2, which only supports up to LabVIEW 2012. How can I add this support to my development environment?
  • When I launch VMS, TestStand or LabVIEW I get a slew of missing .VI's that it is not finding.  I see that I have a run-time already installed.

Solution

NI VMS support can typically be added to later versions of TestStand and LabVIEW that aren't supported by the VMS installer. Note that while the functionality of the VMS software is not officially supported in later versions of LabVIEW and TestStand than those referenced in the software readme, typically these configurations will still work. 

To install support for a newer version of TestStand or LabVIEW, complete the following steps:
  1. Start the VMS installer.
  2. In the Features dialog, select an entry for either TestStand or LabVIEW support, depending on which environment you want to install support for.
  3. Use the Browse button or manually edit the installation path to the TestStand or LabVIEW directory for the version of your choice.
  4. Click Next and follow the prompts to complete the installation.


 

    Additional Information

    Note: The process described in this article cannot be used to install support for a 64-bit version of TestStand. TestStand 64-bit is not supported by VMS.

    Note: This technique will only work if VMS has not yet been installed. Due to the installer process, once VMS has been installed, you will no longer be able to alter the support path. If you have already installed VMS, you will first need to uninstall it before completing the steps listed above. 

    WAS THIS ARTICLE HELPFUL?

    Not Helpful