Cannot Open VI in Newer Version Of LabVIEW Communications

Updated Aug 28, 2018

Reported In

Software

  • LabVIEW Communications System Design Suite
  • LabVIEW Communications System Design Software

Issue Details

I have a project that I created in LabVIEW Communications 1.0.  When attempting to open this project in versions 1.1 or 2.0 of the software, some of the VIs do not load and I see the following error referring to the source file format:
 
Why am I seeing this load error and how do I resolve it?

Solution

There are some incompatibilities between versions of LabVIEW Communications Software, especially when migrating from version 1.0.  Typically, this error occurs when using custom controls or clusters within the software.  If seeing this error, try to remove custom controls and clusters in the VI using the original version of LabVIEW Communications.  You can then rebuild them after opening the file successfully in the new version.

Additional Information

If it is unclear which cluster/control is causing this error message, please reach out to National Instruments support for assistance.

WAS THIS ARTICLE HELPFUL?

Not Helpful