Is My DAQ Device Supported in My Operating System?

Updated May 19, 2020

Reported In

Driver

  • Traditional NI-DAQ
  • Traditional NI-DAQ 7.1
  • NI-DAQmx

Operating System

  • Windows

Issue Details

  • I have data acquisition hardware from NI which is quite old. I have a new machine with Windows 10. Is the device compatible?
  • I am about to buy a new DAQ card, how do I know if it's compatible with my operating system?

Solution

To use a DAQ device, the operating system (OS), driver, and device itself must all be compatible. New DAQ devices work with the NI DAQmx Driver which is compatible with Windows 10 versions 15.5-current,whereas older DAQ devices work with the traditional NI-DAQ Driver which cannot be installed on Windows 10.

You can find out which driver your device is working with in the user manual of the device, or in the driver's Readme file under the sections "Supported Operating Systems" and "Device Support in NI-DAQmx". These two sections will show you if your particular driver will be compatible with your hardware and OS. To get to the Readme file, select the driver version, and click View Readme.

You can use the following tool to find out which version of the DAQmx driver will be compatible with your DAQ device and OS: NI-DAQmx First Available Hardware Support