NI-USRP와 NI-RIO 드라이버 간의 호환성

업데이트 됨 Feb 12, 2019

해당 제품

Hardware

  • USRP Software Defined Radio Reconfigurable Device

Driver

  • NI-USRP
  • NI-USRP 18.0
  • NI-USRP 1.3

문의사항

최근에 NI-RIO를 버전 14.0으로 업데이트했지만, NI-USRP API를 사용하여 PCIe를 통해 USRP 디바이스와 통신 할 수 없습니다. USRP와 통신 할 수 없는 이유는 무엇입니까?

해결책

NI-USRP 1.3과 NI-RIO 14.0 이상은 NI-USRP API를 사용할 때 PCIe를 통한 통신을 방해합니다. 이 장치는 MAX (Measurement & Automation Explorer)에 나타날 수 있습니다.

NI-USRP 1.3은 NI-RIO 13.1.1과만 호환됩니다. NI-USRP 1.3 및 NI-RIO 14.0 이상이 설치된 경우 두 가지 옵션이 있습니다.
  • 호환성 문제를 수정하는 NI-USRP 14.0 이상으로 업그레이드하십시오.
  • NI-RIO 14.0 이상을 제거하고 NI-USRP 1.3 드라이버를 다시 설치하십시오. (이 옵션은 LabVIEW 2014 이상을 사용할 때 권장되지 않습니다.)

이 글이 도움이 되셨습니까?

도움 안됨