Can My Old NI-XNET Device Support CAN-FD ?

Updated Jul 5, 2018

Reported In

Hardware

  • PXI-8512

Issue Details

I have multiple NI-XNET devices of the same model. Some of them are labelled CAN-HS and the newer ones are labelled CAN-FD. Can all of them support CAN-FD or only the newer ones ?

Solution

Every CAN-HS interface supports CAN-FD, so even the older revisions of the NI-XNET devices can be used.

Additional Information

CAN-FD can be used as long as you have a compatible NI-XNET version. NI-XNET supports CAN-FD in version 14.0 or later.

WAS THIS ARTICLE HELPFUL?

Not Helpful