Software Required to Activate the Xilinx Compilation Tools

Updated Sep 26, 2018

Reported In

Software

  • FPGA Xilinx Compilation Tools
  • LabVIEW FPGA Module
  • LabVIEW

Issue Details

I am trying to use the Xilinx Compilation Tools on my machine, but am being prompted to activate a license when I try to compile. However, the Xilinx Compilation Tools do not show up in NI License Manager. Am I missing software required to activate it?

I may also get the following error code:

Error −61247: The VI cannot be compiled for FPGA. The VI belongs to an NI toolkit that is currently in evaluation mode.

Solution

The Xilinx Compilation Tools will activate via the associated version of the LabVIEW FPGA Module. Ensure that your LabVIEW FPGA Module (and any other toolkits you are using in your code) are not in evaluation mode. You may need to double-check that the FPGA Module is still activated if you are getting prompted after previously activating the LabVIEW FPGA Module.
In case the FPGA Module is activated and you are still being asked for the serial number, use the serial number for the FPGA Module. 

Additional Information

Make sure you are installing your software in this order before attempting to use the Xilinx Compilation Tools:
  1. LabVIEW
  2. LabVIEW FPGA Module
  3. Xilinx Compilation Tools

WAS THIS ARTICLE HELPFUL?

Not Helpful