.NET Framework Version Installed by LabVIEW

Updated Jun 1, 2018

Reported In

Software

  • LabVIEW
  • LabVIEW Run-Time Engine

Issue Details

I am going to install LabVIEW or LabVIEW Run-Time Engine and I need to know which version of .NET Framework will be installed to check compatibility with other third-party software components.
 

Solution

.NET Framework version required in order to install LabVIEW depends on your LabVIEW version, as shown in the following table (which covers only the most recent LabVIEW versions):
 
LabVIEW Version.NET Framework Version
20184.6.2
20174.6.2
20164.6.1
20154.5.2
 

Additional Information

You can refer to LabVIEW readme file available at your specific LabVIEW download page or, if LabVIEW is already installed, in folder C:\Program Files (x86)\National Instruments\LabVIEW xx\readme to check which .NET Framework is required. This is typically indicated under System Requirements section.
 

WAS THIS ARTICLE HELPFUL?

Not Helpful