Drivers Required for CAN over EtherCAT

Updated May 28, 2018

Reported In

Driver

  • NI-XNET
  • NI-CAN
  • NI-Industrial Communications for EtherCAT

Issue Details

I want to implement a new application where I use LabVIEW to control CAN communication between a cRIO and an EtherCAT device. What drivers do I need?

Solution

These are the drivers you will need:
  1. NI-Industrial Communications for EtherCAT
  2. NI-XNET
The version of the drivers must be compatible to the version of your LabVIEW Development Environment.

See the related links for compatibility information and more on working with pre-existing applications that use NI-CAN.

WAS THIS ARTICLE HELPFUL?

Not Helpful