NI USB-TC01 Firmware Is Too New

Updated May 24, 2018

Reported In

Hardware

  • USB-TC

Driver

  • NI-DAQmx

Issue Details

I am attempting to use my NI USB-TC01 device, and receive the message Status Code: -201165 Firmware for this device is too new in NI MAX:

Is it possible to downgrade the firmware?

Solution

This error message is received when the USB-TC01 device has firmware version 1.1.0f1 or later and the system has DAQmx version 14.1 or earlier. This new version of the firmware is only compatible with DAQmx 14.5 or later. All customers that purchase the new USB-TC01 receive the letter below along with the device that explains the USB-TC01 and DAQmx compatibility. 


All of the USB-TC01 devices that we sell contain the new version of the firmware. There is no option to downgrade the firmware on the USB-TC01 to make it work with older versions of DAQmx.

If it is not possible for you to upgrade your version of NI-DAQmx, contact NI support to discuss alternatives.

 

Additional Information

It is possible to upgrade the firmware of NI USB-TC01 devices, see the Related Links section for the download link. Do not upgrade the firmware if you are using DAQmx version 14.1 or earlier as the TC-01 will become incompatible. 

WAS THIS ARTICLE HELPFUL?

Not Helpful