エラー -88716: MAXのリアルタイム(RT)コントローラでエラーが発生する

更新しました Sep 17, 2019

使用製品

Hardware

  • PXI Controller
  • CompactRIO Controller

Software

  • Measurement & Automation Explorer (MAX)
  • VeriStand

Driver

  • NI-DAQmx

問題

  • DAQデバイスを含むPXIシャーシにリアルタイム(RT)コントローラがあります。MAXを開いて、DAQmxグローバル仮想チャンネルのいずれかをクリックすると、エラー-88716が表示されます。パッチをインストールした後、このエラーを受け取り始めました。このエラーを解決するにはどうすればよいですか?
  • DAQデバイスを含むcRIOコントローラがあります。MAXを開いてテストパネルをクリックすると、エラー-88716が表示されます。

解決策

このエラーは、ホストコンピュータとリモートターゲットのDAQmxドライババージョンの不一致が原因です。このエラーを解決する方法は、以下のとおりです。
 

  1. MAXを起動して、リモートシステムの下でRTターゲットを見つけます。
  2. RTターゲットの名前の横にある「+」記号をクリックして、RTターゲットに属するすべてのフォルダーを表示します。
  3. ソフトウェアフォルダを右クリックして、ソフトウェアの追加と削除を選択します。
  4. ソフトウェアのリストでDAQmxドライバを見つけて、ソフトウェアバージョン間の競合()を確認します。
  5. 競合がある場合は、ホストマシンとターゲットマシンで一致するように正しいバージョンのDAQmxをインストールします。
  6. 正しいバージョンのDAQmxがドロップダウンメニューにない場合は、DAQmxドライバを再インストールし、Real-Time Supportを選択します


ドライババージョンが1つしかインストールされておらず、それでもエラーが発生する場合は、MAXデータベースのリセットを試します。
 

追加情報

メモ: ホストPCとRTターゲットでドライバのバージョンが異なるデバイス(シリアルデバイスなど)に対して同じメッセージが表示されます。

この記事はお役に立ちましたか?

いいえ