Archived:LabVIEW Version Compatibility With LabVIEW Robotics Module

Updated May 3, 2021

National Instruments does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Reported In

Software

  • LabVIEW Robotics Module
  • LabVIEW Full
  • LabVIEW Professional

Issue Details

Is the LabVIEW Robotics Module 2017 compatible with the LabVIEW 2018 currently installed on my computer?

Solution

The module year should always match the LabVIEW version year. In this case, LabVIEW Robotics Module 2017 is not compatible with LabVIEW 2018, only 2017. In addition, the Robotics module requires the Full or Professional Development system of LabVIEW.

Refer to the LabVIEW 2017 Robotics Module Readme for the system requirements, or review other readmes.