Error -2147138268 Downloading FPGA Code to NI 9144 EtherCAT Chassis

Updated Nov 8, 2018

Reported In

Hardware

  • NI-9144

Software

  • LabVIEW

Driver

  • NI-RIO

Issue Details

After compiling my FPGA code, I try downloading it to an NI 9144 EtherCAT chassis and get the following message: Error -2147138268 occurred at EcatIsDownloadNecessary.vi:1.  How do I resolve this error and successfully download my FPGA code to my EtherCAT target?

Solution

This error is generally caused by failing to deploy the EtherCAT master.
To do this right-click the EtherCAT master and select Deploy.

This error can also be associated with a firmware mismatch between the NI 9144 and the NI-RIO and NI-Industrial Communications for EtherCAT drivers. In order to successfully download your FPGA code, update the firmware on your NI 9144. This process is outlined on pages 15-16 of the NI 9144 User Manual.

WAS THIS ARTICLE HELPFUL?

Not Helpful