TestStand LabVIEW NXG's Adapter Compatiblity

Updated Nov 20, 2018

Reported In

Software

  • TestStand
  • LabVIEW NXG

Issue Details

  • My TestStand Sequence Editor is missing the LabVIEW NXG adapter.
  • I cannot select the LabVIEW NXG adapter in the TestStand Sequence Editor.
  • I am using TestStand with LabVIEW NXG. However, when I make a LabVIEW NXG module, it is asking for a GLL rather than a GVI. So far, I have been changing the LabVIEW NXG Adapter so that it uses the Development System rather than the Run-Time Engine as explained here. However, since I installed LabVIEW NXG 2.1, I cannot do that as the Adapters Configuration window is grayed out as shown below: 
 

Solution

  1. Make sure you are using the TestStand 64-bit Sequence Editor.
  2. Check the TestStand's readme to find the LabVIEW NXG versions that are compatible with the release.
    • For example: TestStand 2017 is compatible with LabVIEW NXG 2.0. If you use a higher LabVIEW NXG version than the one mentioned in the readme file, you will see the Adapter Configuration window grayed out.

Additional Information

LabVIEW NXG works solely in 64-bits, and therefore requires to be called from the TestStand's 64-bit Sequence Editor. Therefore, the TestStand 32-bit Sequence Editor will not show the LabVIEW NXG adapter at all. More information here: LabVIEW NXG Adapter.

WAS THIS ARTICLE HELPFUL?

Not Helpful