Required Software for Industrial Controller

Updated Jun 7, 2018

Reported In

Hardware

  • Industrial Controller
  • IC-3173

Software

  • LabVIEW
  • Vision Development Module
  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module
  • Vision Builder for Automated Inspection

Issue Details

What software should I install in order to use NI Industrial Controller?

Solution

A summary of the required components to program the Industrial Controllers with LabVIEW or Vision Builder for Automated Inspection is shown below:
  • LabVIEW
    • LabVIEW Real-Time Module is required to program Industrial Controllers with the NI Linux Real-Time OS. LabVIEW Real-Time Module is not required to program Industrial Controllers with the WES7 OS
    • Vision Development Module is necessary if you need to implement image processing functions on Industrial Controllers
    • LabVIEW FPGA Module is only required if you would like to program the FPGA for image coprocessing or custom triggering. The Industrial Controllers FPGAs are shipped pre-programmed for the Vision RIO personality which offers common digital I/O and triggering functionality
    • Industrial Controller Device Drivers 15.5 or older
    • NI Device Drivers February 2016 or older
  • Vision Builder for Automated Inspection
    • Vision Builder for Automated Inspection 2015 or older
    • Industrial Controller Device Drivers 15.5 or older
    • NI Device Drivers February 2016 or older

Additional Information

NI Hardware, such as NI Industrial Controller, includes Vision Acquisition Software license.

WAS THIS ARTICLE HELPFUL?

Not Helpful