VeriStand 2017 UI Manager Crashes When Opening UI From Earlier Version

Updated Jun 5, 2018

Reported In

Software

  • VeriStand

Issue Details

I have some VeriStand UI's from VeriStand 2016 and when I try to open them in VeriStand 2017, I get the error shown below.

 

 
Followed by this window:

 


 
Why can't I open my older UI's in VeriStand 2017?

Solution

This behavior is a known bug and it is caused by boolean controls on the UI.

To avoid the error:
1. Open the UI in the original version of VeriStand that it was created in
2. Remove any boolean controls and save it.
3. You will now be able to open the UI in VeriStand 2017.

Additional Information

This has been submitted as a CAR and has been fixed for VeriStand 2018.

WAS THIS ARTICLE HELPFUL?

Not Helpful