Error Installing LabVIEW Interface for Arduino Toolkit Using VI Package Manager

Updated Jul 17, 2018

Reported In

Software

  • LabVIEW
  • JKI VI Package Manager
  • Third Party Add-Ons

Other

  • LabVIEW Interface for Arduino 2.2.0.79

Issue Details

I am trying to install LabVIEW Interface for Arduino 2.2.0.79 (LIFA) using VI Package Manager. The installation fails and I get this error message:

VIPM could not install the package national_instruments_lib_labview_for_arduino-2.2.0.79

Solution

This specific issue can be solved by executing VI Package Manager (VIPM) with administrator rights. To run VI Package Manager as administrator:

  1. Right-click VI Package Manager in File Explorer
  2. Select Run as administrator

Additional Information

Note: The package LabVIEW Interface for Arduino (LIFA) has been replaced with LINX. It is highly recommended to migrate to LINX as there will be no further development for LIFA. See How To Download Digilent LINX For LabVIEW? for more information.

LabVIEW Interface for Arduino (LIFA) is a third-party Add-On for LabVIEW. National Instruments gives support for it through the ni.com/arduino Discussion Forum. This forum is constantly monitored by Arduino/LabVIEW users. You can also find documents, examples, and share knowledge there.

WAS THIS ARTICLE HELPFUL?

Not Helpful