LabVIEW and Linux Compatibility

Updated Oct 30, 2018

Reported In

Software

  • LabVIEW
  • LabVIEW Base
  • LabVIEW Full
  • LabVIEW Professional

Operating System

  • Linux

Issue Details

I want to use LabVIEW on my Linux machine. What is LabVIEW's compatibility with Linux?

Solution

Linux supports the Full and Professional versions of LabVIEW but does not support Base. The only flavors of Linux that are currently supported are Red Hat versions 6.x and 7.x, CentOS version 7.x, and OpenSUSE Leap 42.2 and 42.3. For further information on the drivers and software support for Linux, seeĀ National Instruments Driver and Software Support for Linux Distributions.

Additional Information

For information on how to install LabVIEW on Linux see LabVIEW Installation Guide.

WAS THIS ARTICLE HELPFUL?

Not Helpful