Does NI-XNET Support the J1939 Protocol?

Updated Jun 15, 2018

Reported In

Software

  • LabVIEW

Driver

  • NI-XNET

Other

SAE J1939

Issue Details

I am using the SAE J1939 protocol in my system. Do NI-XNET products have support for J1939?

Solution

NI-XNET has native support for J1939 as of version 15.0. You can download NI-XNET through our website. Make sure the version of NI-XNET is compatible with your version of LabVIEW (if using LabVIEW). You can find examples through the NI Example Finder in LabVIEW (Help >> Find Examples >> Search for 'J1939'). 

If you are unable to use version 15.0 or newer of NI-XNET, NI does offer the J1939 Transport Protocol Reference Example.

WAS THIS ARTICLE HELPFUL?

Not Helpful