Can't Install NI Daqmx Base Driver on Scientific Linux 7.x

Updated May 24, 2018

Reported In

Driver

  • NI-DAQmx Base

Operating System

  • Linux

Issue Details

I tried to install the NI DAQmx base drivers on Scientific Linux 7.x and it failed during the nivisa install phase. 
The error: too few arguments to function ‘do_munmap’ shows up in the log file.
 

Solution

NI DAQmx Base failed to install on Scientific Linux 7.x because Scientific Linux 7.x is not supported on NI DAQmx Base. The latest version of Scientific Linux that is supported is Scientific Linux 6. Please refer to this article for a complete table of DAQmx Base and Operating Systems compatibility. 

WAS THIS ARTICLE HELPFUL?

Not Helpful