我可以为早期版本的LabVIEW运行时构建应用程序吗?

更新 Nov 24, 2021

适用于

软件

  • LabVIEW
  • LabVIEW Run-Time Engine
  • LabVIEW Application Builder Module

问题详述

  • 我在计算机上使用的是最新版本的LabVIEW,并且需要为仅具有旧版LabVIEW运行引擎的计算机构建应用程序。
  • 是否可以为早期版本的LabVIEW运行引擎构建应用程序?
  • LabVIEW可执行程序是否与旧版LabVIEW运行引擎兼容?

解决方案

不能。构建可执行程序时,运行引擎依赖关系是由用于创建可执行程序的开发环境定义。
因此,请您确保LabVIEW运行引擎的版本与开发系统的版本匹配。
 
有两个选项可让您成功运行LabVIEW应用程序:
1.目标计算机需要正确版本的运行引擎。您可通过LabVIEW下载页面单独的下载页面(示例链接至LabVIEW Run-Time 2018)免费下载LabVIEW运行引擎版本。
 
2.应用程序将需要在正确版本的开发环境中构建。如果您的NI.com帐户具有有效的SSP订阅,则可以从LabVIEW下载页面下载较旧版本的LabVIEW开发环境。

相关信息

要将项目转换为较旧版本的LabVIEW,请参考将LabVIEW文件恢复为先前版本