LabVIEW與RT模組和LabVIEW FPGA模組的相容性

更新 Nov 12, 2020

產品資訊

軟體

  • LabVIEW
  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module

問題敘述

我需要使用哪個版本的LabVIEW Real-Time和LabVIEW FPGA模組才能使用當前版本的LabVIEW?

解決方案

要將當前版本的LabVIEW與LabVIEW Real-Time和LabVIEW FPGA模組一起使用,您需要安裝與使用年份對應的模組。如果要升級到某個軟體的較新版本,則還必須升級到其他軟體的相應版本。

例如:對於LabVIEW 2018,您需要LabVIEW Real-Time 2018和LabVIEW FPGA 2018。

相關資訊

LabVIEW模組僅與其所構建的版本相容。有關相容性的更多信息,請查看每個模組的Readme文件。僅當存在LabVIEW Module的SP1版本時,SP1版本也會相容。
您可以查看LabVIEW FPGA ModuleLabVIEW Real-Time Module下載頁面,以查看該年是否發布了SP1版本。

例如

  • LabVIEW 2017 SP1的相容如下:
    • LabVIEW Real-Time Module 2017
    • LabVIEW FPGA Module 2017 SP1
  • LabVIEW 2018 SP1的相容如下:
    • LabVIEW Real-Time Module 2018 SP1
    • LabVIEW FPGA Module 2018


在開發電腦上安裝LabVIEW,LabVIEW Modules和NI驅動程式時,安裝軟體的順序很重要。請按照本指南安裝軟體產品:Installing LabVIEW, LabVIEW Real-Time and FPGA Modules, and NI-RIO