LabVIEW Compatibility With the Real-Time and LabVIEW FPGA Modules

Updated Feb 22, 2019

Reported In

Software

  • LabVIEW
  • LabVIEW Real-Time Module
  • LabVIEW FPGA Module

Issue Details

Which version of the LabVIEW Real-Time and LabVIEW FPGA module do I need to work with my current version of LabVIEW?

Solution

To use your current version of LabVIEW with the LabVIEW Real-Time and LabVIEW FPGA modules, you need to install those that correspond to the year you are using. If you upgrade to a newer version of one software, you must also upgrade to the corresponding versions of the others. 

For example: For LabVIEW 2018 you need LabVIEW Real-Time 2018, and LabVIEW FPGA 2018.

Additional Information

The LabVIEW Modules are only compatible with the version they are built for. For more information about compatibility, review the readme file of each module. This is also true for SP1 versions.
For example: For LabVIEW 2018 you need LabVIEW Real-Time 2018, and LabVIEW FPGA 2018. Using LabVIEW Real-Time 2018 SP1 and LabVIEW FPGA 2018 SP1 will work only with LabVIEW 2018 SP1.

When installing LabVIEW, LabVIEW Modules, and NI drivers on your development computer, the order in which you install the software is important. Follow this guide to install your software products: Installing LabVIEW, LabVIEW Real-Time and FPGA Modules, and NI-RIO

WAS THIS ARTICLE HELPFUL?

Not Helpful