DAQExpress and DAQmx Compatibility

Updated May 16, 2019

Reported In

Software

  • DAQExpress 1.0
  • DAQExpress 2.0
  • DAQExpress

Issue Details

  • What versions of DAQExpress and NI-DAQmx are compatible?¬†
  • I upgraded from SignalExpress to DAQExpress and I can no longer see my hardware. Why?

Solution

DAQExpress must be using compatible hardware and a compatible version of NI-DAQmx for it to communicate with NI hardware.

You can check the Readme for NI-DAQmx to verify it's compatibility with DAQExpress. For example, by checking the readme for the NI-DAQmx version 17.0 to 18.6 we can determine the following:
  • DAQExpress 1.0 must be used with NI-DAQmx 17.0 to 17.5
  • DAQExpress 2.0 must be used with NI-DAQmx 17.6 to 18.0
  • DAQExpress 2.1 must be used with NI-DAQmx 18.1 to 18.6

Additional Information

Note: Upgrading from SignalExpress to DAQExpress may have upgraded the NI-DAQmx version that no longer supports your hardware.

WAS THIS ARTICLE HELPFUL?

Not Helpful