Image Display Control Is Inactive in Vision Development Module Executable

Updated Jun 7, 2018

Reported In

Software

  • Vision Development Module
  • LabVIEW Application Builder Module

Driver

  • Vision Acquisition Software

Other

LabVIEW 2012 64-bit

Issue Details

When I work in the LabVIEW development environment, everything works as expected with my image display control:
But when I build my VI into a 64-bit executable with the Vision Development Module (VDM) 2012, the image display control shows as black or blank, and I cannot interact with it:

Solution

This has been observed in VDM 2012. The way to fix this is to copy Vision components from the LabVIEW 2011 Run-Time Engine 64-bit folder, and paste these components into the 2012 64-bit folder.  There are two folders of files that need to be copied.

Usually, these files are located here:
  • C:\Program Files\National Instruments\Shared\LabVIEW Run-Time\2011\PlugInControls
  • C:\Program Files\National Instruments\Shared\LabVIEW Run-Time\2011\resource\objmgr

If these are copied to the corresponding 2012 locations, this should fix the issue:
  • C:\Program Files\National Instruments\Shared\LabVIEW Run-Time\2012\PlugInControls
  • C:\Program Files\National Instruments\Shared\LabVIEW Run-Time\2012\resource\objmgr

Once these files have been copied, the image display should work properly: 

Additional Information

This happens because Vision Common Resources 12.0.0 does not include The LabVIEW Run-Time Engine 64-bit files for Vision. If you need a fixed installer, you can download Vision Common Resources 2012 f1.

WAS THIS ARTICLE HELPFUL?

Not Helpful