NI-RFmx LTE Software Dependencies

Updated Apr 13, 2018

Reported In

Software

  • NI-RFmx LTE/LTE-Advanced
  • NI-RFmx LTE TDD/FDD
  • LabVIEW

Issue Details

I am planning on using RFmx LTE, but I don't know what additional software I will need to install. Are the dependencies for RFmx LTE listed anywhere?

Solution

According to the RFmx LTE 2.4 readme, the necessary software you will need is:
  • An application development environment (ADE)
    • NI LabVIEW 2014 SP1 f5 (32-bit) patch, 2014 SP1 f6 (64-bit) patch, 2015 SP1 f5 patch, 2016, or 2017
    • Microsoft Visual Studio 2010 SP1 or later
  • NI-RFSA driver
    • NI-RFSA 14.1 or later
    • NI-RFSA 17.1 or later (for initializing debug session when using breakpoints in C/C++/.NET application is selected)

Additional Information

Note:  NI-RFmx LTE does not operate correctly without the service packs and patches listed. Also, the bullets for NI-RFSA correspond with the ADE bullets.

WAS THIS ARTICLE HELPFUL?

Not Helpful