NI MAX Warning Installing Remote Panel Server for LabVIEW RT

Updated Sep 3, 2019

Reported In

Hardware

  • PXI Controller
  • CompactRIO Controller

Software

  • LabVIEW Real-Time Module
  • LabVIEW Remote Panel Server
  • LabVIEW

Issue Details

I would like to install the Remote Panel Server on my Real-Time target using a recent LabVIEW Real-Time version. During the installation process NI MAX shows the following warning when selecting the Remote Panel Server for LabVIEW RT entry in the Software Wizard:
"Allows accessing VIs as remote panels. This version of the Remote Front Panel Server requires LabVIEW Real-Time 2010. This component does not automatically downgrade. Refer to the RT 2010 Known Issues for a workaround."




Do I have to downgrade my LabVIEW Real-Time version or can I install the Remote Panel Server anyway?
 

Solution

The warning observed in NI MAX is an artifact which can be ignored. Remote Panel Servers are still supported for LabVIEW RT and they can be installed using the corresponding entry in the Software Wizard.

 

 

Additional Information

Please note that there have been some changes to the Remote Panel Server, mostly noted in this article.
National Instruments typically does not recommend to use Remote Panel Servers today, as they are outdated and require older browsers. It is typically recommend to configure a HMI VI that communicates with the Real-Time target or to use a WebService.