An Error Occurred While Installing a Package: NI-VIPM (19.x) or (20.x)

Updated Aug 13, 2020

Reported In

Software

  • JKI VI Package Manager
  • Package Manager
  • LabVIEW 2019
  • LabVIEW 2020

Issue Details

While trying to install LabVIEW 2020 or 2019 and Drivers using NI Package Manager, the following error message pops up:

Figure 1: Error message example from NI Package Manager
 

Solution

The source of this issue is undefined, but the solution and troubleshooting steps should be followed as below:

1) Ensure internet connection is solid (browse to any URL).
2) Click 'Try Again' one or two more times.
3) Disable any firewalls or Windows Defender options.
4) Uncheck the JKI PM selection under Add-On's when installing the list of LabVIEW products. You'll need to uncheck it again on the next screen. If the installation succeeds, you can download JKI Package Manager from this website .
5) If possible, try the installation on another computer.

Additional Information

If this error description involves other software packages (such as add-ons/drivers), execute step 4 for the package at fault.