如何在LabVIEW中建立Library File?

更新 Jun 30, 2019

產品資訊

Software

  • LabVIEW Full

問題敘述

如何從新創建的VI或現有的VI建立Library File(LLB)?

解決方案

LabVIEW 8.5及更高版本:
1.建立新project 或打開現有project。若要從block diagram 或 front panel中創建新project,請選擇File»New»Project»Empty Project。若要從LabVIEW Getting Started視窗建立新project,請選擇Empty Project 。

2.右鍵點擊My Computer»New»File,將VI添加到project中。

3.右鍵點擊Build Specifications»New»Source Distribution
4.在左側的Category列表中選擇Source Files

5.從“Project Files”視窗中選擇一個VI,然後點擊右箭頭按鈕讓LLB的VI加到Always Included。

6.在Source distribution properties視窗左側的Category列表中點選Destinations

7.勾選“Destination type”選項下的“ LLB”按鈕。

對於LabVIEW 8.0和8.2:
1.右鍵點擊Build Specifications»New»Source Distribution

2.點擊“ Custom

3.點擊“Destination is LLB”選項,然後在跳出的視窗中選擇“Yes”。



4.點選“ Build.

將現有VI放入新LLB文件的另一種方法如下:
1.從“File”選單中選擇“ Save As ”。
2.選擇Substitute Copy for Original (原始VI將保持不變,其副本將保存在其他位置)。
3.點擊“ Continue 
4.點擊右下角的New LLB按鈕。選擇New LLB文件的名稱和位置。

5.將VI保存在新LLB文件中。

要創建新VI並將其保存在新LLB中,請打開空白vi並從“File”選單中選擇“ Save ,然後按照步驟4和5進行操作。

注意:此方法不會自動在LLB中包含子VI。如果您需要在LLB中包含相依的VI,請遵循以下文章中的說明:  How Do I Create a LabVIEW VI Library that Automatically Includes All SubVIs?

處理LLB的另一種方法是使用LLB Manager(LabVIEW 8.5及更高版本):
1.進入Tools»LLB Manager...
2.找到要保存新LLB的文件夾

3.選擇File»New LLB,然後輸入LLB的名稱。
4.要將VI添加到已建立的LLB,請找到VI並從LLB Manager複製它。
5.找到LLB文件,將其打開,然後貼上VI。

 

本文是否有幫助?

無幫助