如何在LabVIEW中创建库文件(LLB)?

更新 Oct 30, 2018

适用于

Software

  • LabVIEW Full

问题详述

如何从新VI或现有VI创建新的LLB文件

解决方案

LabVIEW 8.5及更高版本:
1.创建新项目或打开现有项目。如果您要从程序框图或前面板创建新项目,请选择文件»新建»项目»空项目 。如果您要从开始LabVIEW界面创建新项目,请选择空项目

2.右键单击我的电脑»新建»文件,将VI添加到项目中。

3.右键单击程序生成规范»新建»源代码发布 。

4.在源代码发布属性窗口左侧的类别列表下选择源文件



5.从“项目文件”窗口中选择一个VI,然后单击右边的箭头按钮以保证在创建LLB时包含此VI。

6.在源代码发布属性窗口左侧的类别列表下选择发布 。

7.单击“目标类型”选项下的“ LLB”按钮。


对于LabVIEW 8.0和8.2:
1.右键单击程序生成规范»新建»源代码发布

2.单击“ 自定义”单选按钮。

3.单击“ 发布LLB ”复选框,然后在弹出窗口中单击“ ”。

4.单击“ 生成”

将现有VI放入新LLB文件的另一种方法如下:
1.从“文件”菜单中选择“ 另存为 ”。
2.选择替换复制原件 (原始VI将保持不变,其副本将保存在其他位置)。
3.单击“ 继续”按钮。
4.单击右下角的“ 新建 LLB”按钮。选择新LLB文件的名称和位置。

5.将VI保存在新LLB文件中。

要创建新VI并将其保存在新LLB中,请打开空白vi并从“文件”菜单中选择“ 保存” ,然后按照步骤4和5进行操作。

注意:此方法不会自动在LLB中包含子VI。如果您需要在LLB中包含依赖项,请遵循以下文章中的说明: 如何创建自动包含所有子VI的LabVIEW VI库?

另一种处理LLB的方法是使用LLB管理器(LabVIEW 8.5及更高版本):
1.进入菜单工具»LLB管理器...
2.找到要保存新LLB的文件夹

3.选择文件»新建LLB并输入LLB的名称。
4.要将VI添加到创建的LLB,请找到此VI并从LLB Manager复制它。
5.找到新建LLB文件,将其打开,然后粘贴VI。

 

本文是否有帮助?

无帮助