LabVIEW에서 라이브러리 파일 (LLB)을 만드는 방법은 무엇입니까?

업데이트 됨 Jan 10, 2019

해당 제품

Software

  • LabVIEW Full

문의사항

신규 또는 기존 VI에서 새 LLB 파일을 작성하려면 어떻게 해야 합니까?

해결책

LabVIEW 8.5 및 이후 버전 :
1. 새 프로젝트를 만들거나 기존 프로젝트를 엽니다. 블록 다이어그램이나 프런트 패널에서 새 프로젝트를 생성하려면 파일»새로 만들기»프로젝트»빈 프로젝트를 선택하십시오. LabVIEW 시작하기 화면에서 새 프로젝트를 생성하려면 새 프로젝트를 선택하십시오.

2. 내 컴퓨터»새로 만들기»파일을 마우스 오른쪽 버튼으로 클릭하여 프로젝트에 VI를 추가하십시오.

3. 빌드 스펙»새로 만들기»소스 배포를 마우스 오른쪽 단추로 클릭하십시오.

4. 소스 패포 프로퍼티 창의 왼쪽에있는 범주 목록에서 소스 파일을 선택하십시오.



5. 프로젝트 파일 윈도우에서 VI를 선택하고 오른쪽 화살표 버튼을 클릭하여 VI를 LLB 빌드에 항상 포함시킵니다.

6. 원본 배포 속성 창의 왼쪽에있는 범주 목록에서 대상을 선택합니다.

7. 대상 유형 옵션에서 LLB 단일 선택 단추를 누르십시오.


LabVIEW 8.0 및 8.2 :
1. 빌드 스펙»새로 만들기»소스 배포를 마우스 오른쪽 버튼으로 클릭하십시오.



2. 사용자 정의 단일 선택 단추를 누르십시오.

3. Destination is LLB 확인란을 클릭하고 팝업 창에서 Yes 를 클릭하십시오.



4. 빌드를 클릭 하십시오.

새로운 LLB 파일에 기존 VI를 배치하는 또 다른 방법은 다음과 같습니다 :
1. 파일 메뉴에서 다른 이름 으로 저장을 선택 하십시오.
2. 원본을 대체 복사본으로 선택하십시오 (원본 VI는 변경되지 않고 복사본은 다른 위치에 저장됩니다).
3. 계속 버튼을 클릭하십시오.
4. 오른쪽 아래 모서리에있는 새 LLB 버튼을 클릭하십시오. 새 LLB 파일의 이름과 위치를 선택하십시오.



5. 새로운 LLB 파일 안에 VI를 저장하십시오.

새로운 VI를 생성하고 그것을 새로운 LLB에 저장 하려면 빈 vi를 열고 파일 메뉴에서 저장을 선택하고 4 단계와 5 단계를 따르십시오.

참고 : 이 방법은 LLB에 subVI를 자동으로 포함하지 않습니다. LLB에 의존성을 포함해야하는 경우 다음 문서의 지침을 따르십시오 : How Do I Create a LabVIEW VI Library that Automatically Includes All SubVIs?

LLB를 처리하는 또 다른 방법은 LLB 관리자 (LabVIEW 8.5 및 이후 버전)를 사용하는 것입니다.
1. 도구»LLB 관리자 메뉴로 이동하십시오 .
2. 새 LLB를 저장하려는 폴더로 이동하십시오



3. 파일»새 LLB를 선택하고 LLB의 이름을 입력하십시오.
4. 생성 된 LLB에 VI를 추가하려면 VI로 이동하여 LLB 관리자에서 복사하십시오.
5. LLB 파일을 찾아서 열고 VI를 붙여 넣습니다.

이 글이 도움이 되셨습니까?

도움 안됨